2011年05月31日

XOOPS Cube Legacy 2.1.08aの安装に失敗

 今日XOOPS Cube Legacy 2.1.08aをWindows 7マシンにインストールしようとしたがうまくいかなかった。
 MySQLのバージョンは5.5。PHPは5.3.6。

 インストールウィザードでインストールを開始した後、細かいトラブルがいくつかあってそれは乗り越えたが、データベーステーブル作成の失敗は解消できなかった。
 データベースのCREATE権限がないのか?と思ったが、目的のデータベースにはGRANT ALLを施している。

 グーグルで検索しても同じ症例で悩んでいる人はほとんどいないようだ。上の権限がないのではという指摘があるくらい。

 現時点では下のフォーラムにある情報が原因だと思っている。

XOOPS Cube日本サイトの利用者フォーラム
http://xoopscube.jp/forum/6835

 この中にPHP 5.3.xではXCLが動作しないという情報がある。

 これが本当の原因なら馬鹿らしくてやってられない(知らないって恐いわね(笑))。

 わざわざ古いバージョンのPHPを入れ直さなくてはならないのだろうか。溜息が出る。

2011.5.31火曜

追記 2011.5.31 22:03

PHPのダウンロードページをよく見たら次の警告があった。

If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP

使用中のApacheは2.2だ。これが正解だった。

追記 2011.6.1 6:59
PHP 5.2.17.17をインストールしたらブラウザからphpファイルをクリックしても自動的に開かず、どのアプリで開くか尋ねるダイアログが出るようになってしまった。PHP 5.3.6ではこんなことはなかった。PHPの設定ファイルを調整する必要があるのだろうか。
posted by 堀内悟 at 21:56| Comment(0) | TrackBack(0) | パソコン | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:


この記事へのトラックバック
×

この広告は180日以上新しい記事の投稿がないブログに表示されております。